For announcing and discussing games, getting feedback, asking for hints

Moderators: Pertex, sgreig, Cryophile, jaynabonne, Alex

User avatar
Site Admin
Posts: 2402
Joined: Fri Jun 27, 2003 11:06 pm
Location: London, UK


Postby Alex » Sat Jul 01, 2006 2:35 pm

Burglary! by Himself

"'Burglary!', the game that puts you inside a house with the intent of finding (and stealing) a most precious item. Stealing has never been more text-based!"

Please post any reviews, comments, requests for help etc. to this thread.

User avatar
Posts: 276
Joined: Wed Dec 28, 2005 2:16 am
Location: Ontario, Canada

Burglary! Edit

Postby Overcat » Sat Jul 01, 2006 8:25 pm

Burglary! Edit
!!WARNING!! Possible spoilers below.

This is my attempt at a game 'edit'. It lists bugs/problems and attempts to offer solutions where one is not evident. As time allows, I will edit more games, and complete editing this one. Note that this is NOT a review or an attempt to rate the game.


At all locations...

Type 'look house' results in 'If only you had one of those.' I should think I can look at the house anytime I want, since this is the setting.

S: Code a general command for this?

At the front door...

Typing 'look door' or any other command with 'door' results in 'If only you had one of those.'

S: Add 'door' to the door object's alias property?

At Front of house (west)...

Typo in description: 'Front of house (west). There is a window here with the shade shrouding any *veiw* inside. You can move north to the side (west) of the house.'

Commands to add:
break window?
open window?

Consider this the same for every window.

At the western side of the house...

These two pieces of information are contradictory:

Code: Select all

> look electric meter
This family uses a lot of electricity.  Must be those kids and their crazy nintendo sega games or whatever.

Code: Select all

> examine electric meter
You don't know how to read the meter hence you are robbing a house.

The 'Electric Meter' can't be referred to as 'meter'

S: Add 'meter' to the meter object's alias property?

At Ahh... the garden

The 'something' sticking in the ground can only be accessed via the GUI with a mouse click. Typing 'look something' or anything else with 'something' results in 'I can't see that anywhere.'

Code: Select all

> examine trowel
Black handled with a shiny surface.  Aluminum, maybe?  It's a tough trowel, though pretty dirty and needs to be wiped off.


'wipe trowel' and 'clean trowel' do nothing.

After taking the trowel, the room description still reads...

Code: Select all

Ahh... the garden.  It is full of all sorts of plants and decorations.  Lilies, tulips, irises, one of those "garden globes".  *Something is sticking out of the dirt.*  The pool is east of here.

S: Code a description change for the room when the trowel is taken?

The 'Garden Globe' can't be referred to as 'globe'

S: Add 'globe' to the globe object's alias property?

Code: Select all

> look picnic set
Chairs and a table with cups on it.  Somebody was really living it up today.

But I can't look at the 'cups', or interact with them.

After taking the towel, the room description still reads...

Code: Select all

The pool area.  The water is still and reflects partial moonlight.  There's some plastic lounging chairs and a plastic table with plastic cups.  Lots of plastic there.  *There's a towel lying on the concrete.*  You can move east into the garden and south to the back of the house.

S: Code a description change for the room when the towel is taken?

At The eastern side of the house.

The 'Water Spicket' can't be referred to as 'spicket'

S: Add 'spicket' to the spicket object's alias property?

The Towel and Trowel

I have no idea how to wrap the towel around the trowel. I've tried many commands. More commands to do this are needed. In fact, I won't continue to edit through the rest of the game until I can figure this out. Perhaps I'll peak into the ASL.

General Bugs...

The Startscript runs for both an unsaved and saved game file.

S: Add a $loadmethod$ conditional in the startscript

User avatar
steve the gaming guy
Posts: 558
Joined: Fri Sep 10, 2004 6:47 pm

Postby steve the gaming guy » Tue Jul 11, 2006 9:04 pm

I played this before seeing and utilizing the "game edit" as posted above.


This was pretty cool. At first, I wasn’t sure about it. It seemed a little vague but as I realized that grammar/spelling errors were minimal and the room/object descriptions were detailed, I continued playing. The first goal is to get into the house. That’s a little bit of a chore because the author creatively makes you use two items to get in.
I admit that I “cheated” on that part because I thought I had tried everything and I assumed there was a programming mistake. There wasn’t. It turned out to be a creative puzzle.
It was neat to see the look and examine definitions being different for each object. (Currently being generally discussed in a topic in the forums) Once you look at “picture 1”, the picture changes to a name that describes the picture such as “beach picture”. It was just a nice touch.
I played through the whole thing from start to finish and I have to say that there were a lot of creative touches throughout including the option to write on the post-it notes.
The only real error that occurred through the game is if you open a cabinet or examine a particular item where you find another object, it will always revert to the same description. In other words, let’s say I opened a cabinet (or whatever) and found a pack of gum. If I take the gum and then open the cabinet again, the gum flies out of the inventory back into the room as if you just found it. This happens with several objects during the game.
Without playing through the game again, I can’t think of any other real “bad” things about it. It wasn’t too long. In fact it was on the verge of being too short.
So…in conclusion, it was not a perfect game but the playability, the mad puzzles and attention to detail were great so the final score is:
4 out of 5

User avatar
Posts: 6
Joined: Wed Apr 12, 2006 12:17 am

Postby Himself » Sun Jul 30, 2006 5:58 am

Hey all-
I just checked back at the quest site for the first time in about 2 months and found that my game has been posted! Thank you Mr. Axe Software for doing this. Extra special thanks to Steve: The Gaming Guy for the positive review. This was my first game and I tried to make the mundane chore of exploring a boring house as humorous and stimulating as possible. There are a lot of boring houses in the world. Thank you Overcat for pointing me in the right direction for my next game (if I ever get around to making one). Any advice I can get for making decent games are appreciated. I'm also very happy that you discovered the magical post-it notes. You should stand at the front door and attempt to read the house number for the super ultimate Zork reference of all time.

Return to “Game Announcements and Feedback”

Who is online

Users browsing this forum: No registered users and 0 guests